芦苇小白

1996-04-04

中国 河北

芦苇小白

解决electron 操作Iframe时出现跨域问题

electron9 以下的版本直接设置 new BrowserWindow({ webPreferences: { webSecurity: false, //关闭安全检查 allowRunningInsecureContent: true, // 允许http加载https脚本 } }); 若无效果,继续增加下列代码: // 设置程序属性 app.commandLine.appendSwitch('disa...

1642 2021-06-19 15:04:29

芦苇小白

VUE 集成electron 构建桌面程序脚手架搭建笔记

PS: 换了新系统,重新搭建一下前端环境,顺便记录一下笔记。 安装NodeJs安装Yarnsudo npm install -g yarn 安装Vue cliyarn global add @vue/cli 创建项目并选择组件vue create iexplorer cd iexplorer 添加electron打包支持vue add electron-builder 运行yarn run electron:serve 打包yarn run electron:build 需要优化的一些地方 编辑vu...

1642 2021-05-06 14:18:51